poj1305毕达哥拉斯不定方程

Fermat vs. Pythagoras
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 1140 Accepted: 662

Description

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level.
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2.
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).

Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file

Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.

Sample Input

10
25
100

Sample Output

1 4
4 9
16 27

毕达哥拉斯三元组(本原)满足
x=m*m-n*n;
y=2*m*n;
z=m*m+n*n;
其中 m>n,m为奇数,n为偶数或者m为偶数,n为奇数;
那么要求所给范围内的本原毕达哥拉斯三元组数,只需对m,n分别枚举即可,然后将三元组乘以i(保证i*z在所给范围内),就可以求出所有的毕达哥拉斯三元组
(教材112,数论)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=1000001;
bool flag[maxn];
int gcd(int a,int b)
{
    if(!b)  return a;
    else    return gcd(b,a%b);
}
void solve(int t)
{
    int x,y,z,n,m,ans1,ans2,i,temp;
    ans1=ans2=0;
    memset(flag,0,sizeof(flag));
    temp=sqrt(t+0.0);
    for(n=1;n<=temp;n++)
    {
        for(m=n+1;m<=temp;m++)
        {
            if(m*m+n*n>t)
                break;
            if(n%2!=m%2)
            {
                if(gcd(m,n)==1)
                {
                    x=m*m-n*n;
                    y=2*m*n;
                    z=m*m+n*n;
                    ans1++;
                    for(i=1;;i++)
                    {
                        if(i*z>t)
                            break;
                        flag[i*x]=true;
                        flag[i*y]=true;
                        flag[i*z]=true;
                    }
                }
            }
        }
    }
    for(i=1;i<=t;i++)
    {
        if(!flag[i])
            ans2++;
    }
    printf("%d %d\n",ans1,ans2);

}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        solve(n);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值