poj 1159 Palindrome

题目链接:点击打开链接

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
题目大意:给数字符串的长度和字符串s,问要最少添加几个字符才能构成回文串

基本思路:LIS的变形;找出s和其逆序字符串的最长公共字串,然后n-公共字串的长度即使要添加的字母数

<span style="font-size:18px;">///n-最长公共子序列就是要添加的最少字母组成的回文串

#include <iostream>
#include<cstring>

using namespace std;
short int c[5005][5005];

int main()
{
    int n;
    char s[5005];
    char t[5005];
    while(cin>>n)
    {
        cin>>s;
        int top=0;
        for(int i=n-1; i>=0; i--)
        {
            t[top++]=s[i];
        }
        t[top]='\0';
       // cout<<s<<endl;
        //cout<<t<<endl;
        for(int i=0; i<=n; i++)
        {
            c[i][0]=0;
            c[0][i]=0;
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(s[i-1]==t[j-1])
                    c[i][j]=c[i-1][j-1]+1;
                else
                {
                    if(c[i-1][j]>c[i][j-1])
                        c[i][j]=c[i-1][j];
                    else c[i][j]=c[i][j-1];
                }
            }
        }
        cout<<n-c[n][n]<<endl;
    }
    return 0;
}
</span>


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值