[C++] PAT 1108 Finding Average (20分)

在这里插入图片描述

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题解:

该题参考了柳婼的代码
使用了c++ 中 sscanfsprintf函数
sscanf(a,b,&c) 表示 将ab的形式输入到c中,a为字符数组
sprintf(a,b,c) 表示 将cb的形式输入到a中,b为字符数组

#include <iostream>
#include <string>
#include <string.h>
using namespace std;


int main(){
	int n,cnt=0;
	char a[50],b[50];
	double temp=0.0,sum=0.0;
	cin >> n;
	for(int i=0;i<n;i++){
		scanf("%s",a);
		sscanf(a,"%lf",&temp);
		sprintf(b,"%.2f",temp);
		int flag = 0;
		for(int j =0;j<strlen(a);j++){
			if(a[j] != b[j]) flag=1;
		}

		if(flag || temp < -1000 || temp > 1000){
			printf("ERROR: %s is not a legal number\n",a);
			continue;
		}	
		else{
			sum += temp;
			cnt++;
		}
	}


	if(cnt == 1){
		printf("The average of 1 number is %.2f\n",sum);
	}
	else if(cnt > 1){
		printf("The average of %d numbers is %.2f\n",cnt,sum/cnt);
	}
	else {
		printf("The average of 0 numbers is Undefined\n");
	}
	

	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值