hdu1171---Big Event in HDU(多重背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1171

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 
题目大意:

Problem Description

    目前我们知道Computer College是HDU最大的部门,但是,可能你不知道在2002年,Computer College已经分成Computer College 和 Software College两部分,与此同时,出现了一个问题,所有的设施必须两等分,首先,所有的设施已经被估价,如果两种设施价格相同,则被认为是一样的,假设有N种设施(不同的价格,不同的种类)
 Input

     输入包括多组样例,每组样例第一行输入一个N(0 < N <= 50 ,不通风设施的总数)。接下来N行包括两个整数V(0<V<=50 )和M(0<M<=100 ),分别代表设施的价格和这种设施的个数,你可以假设所有的价格都是不同的,以输入复数结束;

 

 Output

每组样例,打印一行包括两个数A、B,分别代表两个大学可以得到的最大价值,A和B应该尽量相等,同时,保证A不小于B
   也就是使A和B的差值最小

代码实现:

#include <iostream>
#include <cstring>
using namespace std;
int dp[100001];
int value[101],num[101];
int main()
{
    int n,i,j,k;
    while(cin>>n)
    {
        if(n<0)break;
        int sum=0;
        for(i=0; i<n; i++)
        {
            cin>>value[i]>>num[i];
            sum+=value[i]*num[i];
        }
        memset(dp,0,sizeof(dp));
        for(i=0; i<n; i++)
        {
            for(j=1; j<=num[i]; j=j*2)
            {
                for(k=sum/2; k>=j*value[i]; k--)
                {
                    dp[k]=max(dp[k],dp[k-j*value[i]]+value[i]*j);
                }
                num[i]-=j;
            }
        }
        cout<<sum-dp[sum/2]<<" "<<dp[sum/2]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值