hdu 1394 Minimum Inversion Number (树状数组求逆序数)

Problem Description

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意

输入n个数的序列,每次可以将第一个数放到最后面,求这个序列能形成的最小逆序数。

题解

先跑一个树状数组求逆序对,再利用相关的性质加加减减即可。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n, ans, minn, a[5010], t[5010], sum[5010];

int lowbit(int x) {
    return x & (- x);
}

void modify(int pos) {
    while(pos <= n) {
        t[pos] += 1;
        pos += lowbit(pos);
    }
}

int query(int pos) {
    int sum = 0;
    while(pos) {
        sum += t[pos];
        pos -= lowbit(pos);
    }
    return sum;
}

int main() {
    while(~ scanf("%d", &n)) {
        memset(t, 0, sizeof(t));
        ans = 0;
        for(int i = 1; i <= n; i ++)
            scanf("%d", &a[i]);
        for(int i = 1; i <=n; i ++) {
            modify(a[i] + 1);
            ans += i - query(a[i] + 1);
        }
        minn = ans;
        for(int i = 1; i <= n; i ++) {
            ans -= a[i];
            ans += n - a[i] - 1;
            minn = min(minn, ans);
        }
        printf("%d\n", minn);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值