pku 2955 Brackets(区间dp)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2047 Accepted: 1041

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source


题意:找出最大的括号匹配个数
题解:经典区间dp,逐个合并区间,或者若i和j匹配则dp【i】【j】=dp【i+1】【j-1】+1;

#include<stdio.h>
#include<string.h>
int dp[105][105];
char s[105];
int match(int a,int b)
{
    if(s[a]=='('&&s[b]==')') return 1;
    if(s[a]=='['&&s[b]==']') return 1;
    return 0;
}
int MAX(int a,int b){ return a>b?a:b; }
int main()
{
    int i,j,k,l,n;

    while(scanf("%s",s+1)>0)
    {
        if(s[1]=='e') break;
        n=strlen(s+1);
        memset(dp,0,sizeof(dp));
        for(l=1;l<n;l++)
        {
            for(i=1;i<=n-l;i++)
            {
                j=i+l;
                if(match(i,j)) dp[i][j]=dp[i+1][j-1]+1;
                for(k=i+1;k<j;k++)
                {
                    dp[i][j]=MAX(dp[i][j],dp[i][k]+dp[k][j]);
                }
            }
        }
        printf("%d\n",dp[1][n]<<1);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值