pku 1977 Odd Loving Bakers(矩阵快速幂)

Odd Loving Bakers
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 1908 Accepted: 629

Description

There is a group of N bakers in the town of Utopia. These bakers hold a monthly celebration in which they award a prize to some of the luckier among themselves. These lucky guys are chosen as follows: 

In the beginning there are some chalk marks on some of the bakers' houses. Each baker has a list of his/her favorite bakers. After each celebration each of the winners puts a chalk mark on the house of all the bakers in his/her favorite list. Before each celebration those bakers with an odd number of chalk marks on their house will be chosen as winners. As there will be a great prize for the winners of the t th celebration, you are asked to find the number of its winners. 

Input

The first line of the input contains a single integer X (1 <= X <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of each instance contains two integers n (the number of bakers) and t (the number of the celebration we want the winners of). 
1 <= n <= 100 
1 <= t <= 1,000,000,000 
The next n lines of the instance each describe a baker. In each of these lines first comes the name of the baker (names are lower case strings of no more than 20 characters without spaces), then comes the number of chalk marks initially on the baker's house, then comes the number of bakers in this baker's favorite list, and after that come the names of the bakers in this baker's list. 

Output

There should be one line per test case. For each test case write a line containing a single integer, the number of the winners of the t-th celebration.

Sample Input

2
3 2
bessie 2 3 bessie linda mary
mary 1 1 linda
linda 0 1 bessie
2 2	
siavosh 1 2 siavosh mohammad 
mohammad 1 0

Sample Output

2
0

Source


题意:有n个面包师,他们每天进行投票,并会投给他所有仰慕的面包师,若一天他的票数为奇数就会获胜,下一天获胜的人才能投票,问第n天有多少个人获胜

题解:构造一个矩阵,而由于仅和奇偶有关则可以巧妙地用位运算的与和异或只取0和1,由于T【2】=T【1】*(E+A),则矩阵公式有T【n】=T【1】*(E+A)^(t-1)


#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
#include<string>
using namespace std;
struct mat{
    int a[103][103];
}c,res;
int now[103],n,t;
string s;
map<string,int>mip;
void init()
{
    mip.clear();
    memset(c.a,0,sizeof(c.a));
    memset(res.a,0,sizeof(res.a));
    for(int i=0;i<103;i++) res.a[i][i]=1;
}
void input()
{
    scanf("%d%d",&n,&t);
    t--;
    for(int i=0,cou=0,x,y,z;i<n;i++)
    {
        cin>>s;
        if(!mip.count(s)) mip[s]=cou++;
        scanf("%d%d",&x,&y);
        z=mip[s],now[z]=x&1;
        for(int j=0;j<y;j++)
        {
            cin>>s;
            if(mip.count(s)) c.a[z][mip[s]]=1;
            else mip[s]=cou++,c.a[z][cou-1]=1;
        }
    }
}
struct mat mult(struct mat x,struct mat y)
{
    struct mat temp;

    memset(temp.a,0,sizeof(temp.a));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            for(int k=0;k<n;k++)
                temp.a[i][j]^=x.a[i][k]&y.a[k][j];
        }
    }

    return temp;
};
void solve()
{
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        c.a[i][j]^=res.a[i][j];
    }
    while(t)
    {
        if(t&1) res=mult(res,c);
        c=mult(c,c);
        t>>=1;
    }
}
void print()
{
    int ans=0,cc[103];

    for(int i=0;i<n;i++) cc[i]=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
            cc[j]^=now[i]&res.a[i][j];
    }
    for(int i=0;i<n;i++) ans+=cc[i];
    printf("%d\n",ans);
}
int main()
{
    int x;

    scanf("%d",&x);
    while(x--)
    {
        init(); input(); solve(); print();
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值