bellman判断负权回路--poj3259

Language:
Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25559 Accepted: 9177

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,   F.   F  farm descriptions follow.  
Line 1 of each farm: Three space-separated integers respectively:   N,   M, and   W  
Lines 2.. M+1 of each farm: Three space-separated numbers ( S,   E,   T) that describe, respectively: a bidirectional path between   S  and   E  that requires   T  seconds to traverse. Two fields might be connected by more than one path.  
Lines   M+2.. M+ W+1 of each farm: Three space-separated numbers ( S,   E,   T) that describe, respectively: A one way path from   S  to   E  that also moves the traveler back   T  seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题意:FJ的农场有很多鼠洞,可以实现时光倒流,现在给你农场每条道路的起点、终点和时间,还有鼠洞的起点、终点和能倒流的
时间,问FJ能不能通过时光倒流看到之前的自己。

思路:把道路起点终点看做节点构图,能倒流的边权值为负,用bellman算法判断是否存在负权回路,存在就可以。
需要注意的是边是双向的,因为这个wa了一次

代码如下:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int inf=1000000000;
struct node
{
    int u,v,t;
} farm[5500];
int dis[550];
int vis[550];
int p;
int n,m,w;
bool bellman()
{
    for(int i=1; i<=n; i++)
    {
        dis[i]=inf;
    }
    dis[1]=0;
    vis[1]=1;
    bool flag;
    for(int i=1; i<n; i++)
    {
        flag=false;
        for(int j=1; j<=p; j++)
            if(dis[farm[j].v]>dis[farm[j].u]+farm[j].t)
            {
                dis[farm[j].v]=dis[farm[j].u]+farm[j].t;
                flag=true;
            }
        if(!flag)
            break;
    }
    for(int j=1; j<=p; j++)
        for(int j=1; j<=p; j++)
            if(dis[farm[j].v]>dis[farm[j].u]+farm[j].t)
            {
                dis[farm[j].v]=dis[farm[j].u]+farm[j].t;
                return true;
            }
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int q;
    int s,e,t;
    cin>>q;
    while(q--)
    {
        cin>>n>>m>>w;
        p=1;
        memset(farm,0,sizeof(farm));
        for(int i=1; i<=m; i++)
        {
            cin>>s>>e>>t;
            if(farm[p].u==s&&farm[p].v==e)
                farm[p].t=min(farm[p].t,t);
            else
                farm[p].t=t;
            farm[p].u=s;
            farm[p].v=e;
            p++;
            if(farm[p].u==e&&farm[p].v==s)
                farm[p].t=min(farm[p].t,t);
            else
                farm[p].t=t;
            farm[p].u=e;
            farm[p].v=s;
            p++;
        }
        for(int i=1; i<=w; i++)
        {
            cin>>s>>e>>t;
            farm[p].u=s;
            farm[p].v=e;
            farm[p].t=min(farm[p].t,-t);
            p++;
        }
        if(bellman())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值