poj-3259-- Wormholes(负边权穿越虫洞问题)

题目:
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题意
;从一些场地开始,穿过一些路径和虫洞,并在他最初离开前一段时间返回起跑场。(穿越虫洞时能让他后退并且时间倒流)
说白了把时间看作是距离只不过在穿越虫洞时距离变成了负的而已这也就是负边;这也算是一个模板题吧:
有不懂的可以参考我的上一篇博客:
https://blog.csdn.net/weixin_44606952/article/details/99205308
AC代码:

#include<stdio.h>
int inf=99999999;
int dis[30005];
int u[30005],v[30005],w[30005];
int main()
{
	int n,m,t,s,a,b,c;
	scanf("%d", &t);
	while(t--)
	{
	    scanf("%d %d %d", &n,&m,&s);
	    for(int i=1; i<=2*m;)
	    {
	    	scanf("%d %d %d", &a,&b,&c);
	    	u[i]=a; v[i]=b;w[i]=c; i++;
	    	u[i]=b; v[i]=a;w[i]=c; i++;	
		}
		for(int i=2*m+1; i<=2*m+s; i++)
		{
			scanf("%d %d %d", &a,&b,&c);
	    	u[i]=a; v[i]=b; w[i]=-c; 
		}
		for(int i=1; i<=n; i++)
		   dis[i]=inf;
		dis[1]=0;	
		for(int k=1; k<=n-1; k++)
		{
			for(int i=1; i<=2*m+s; i++)
		   {
		   	 if(dis[v[i]]>dis[u[i]]+w[i])
		   	 	dis[v[i]]=dis[u[i]]+w[i];
		   }
		}
		   int flag=0;
		for(int i=1; i<=2*m+s; i++)
		  {
		   	 if(dis[v[i]]>dis[u[i]]+w[i])
		   	   flag=1;
		   }
		 if(flag==1)
		 printf("YES\n");
		 else
		 printf("NO\n"); 
	}
	return 0;
}
  • 3
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值