POJ 1573 Robot Motion (模拟+不回溯的dfs 水题)

这篇博客介绍了如何使用模拟和不回溯的深度优先搜索(DFS)方法来解决POJ 1573这个机器人运动问题。文章提供了解题思路,包括输入输出格式,并给出了样例输入和输出,适合初学者练习。
摘要由CSDN通过智能技术生成
Robot Motion
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9159 Accepted: 4441

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source


题意:
机器人根据矩阵里的指令上下左右移动,问机器人经过多少步走出矩阵,如果进入一个环的话,问经历多少步,进入了多少步的环。

分析:就是简单的模拟啊。。。

感想:这种水题都能wa一次。就是因为没有考虑边界情况,比如:1 2 1 EW
         可以是0 step(s)进入循环圈。所以memset应该把vis都清成-1.当vis[][]!=-1就成环。
         还有是字符啊,==要‘ ’的呀。。。

代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#define N 0
#define S 1
#define W 2
#define E 3
using namespace std;

char maps[15][15];
int vis[15][15];
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};
int sum1,sum2,dd;
int r,c;

void fuc(int x,int y,int steps)
{
    int xx,yy,t;
    vis[x][y]=steps;
    if(maps[x][y]=='N')
        t=N;
    else if(maps[x][y]=='S')
        t=S;
    else if(maps[x][y]=='W')
        t=W;
    else
        t=E;
    xx=x+dx[t];
    yy=y+dy[t];
    if(vis[xx][yy]!=-1)
    {
        sum1=steps+1-vis[xx][yy];
        dd=vis[xx][yy];
        return;
    }
    else if(xx<=0||xx>r||yy<=0||yy>c)
    {
        sum2=steps+1;
        return;
    }
    else
        fuc(xx,yy,steps+1);
}

int main()
{
    int sc;
    while(scanf("%d%d%d",&r,&c,&sc)&&r&&c&&sc)
    {
        sum1=0,sum2=0,dd=0;
        memset(vis,-1,sizeof(vis));
        for(int i=1;i<=r;i++)
            scanf("%s",maps[i]+1);
        fuc(1,sc,0);
        if(sum1)
            printf("%d step(s) before a loop of %d step(s)\n",dd,sum1);
        else if(sum2)
            printf("%d step(s) to exit\n",sum2);
    }
    return 0;
}

11946210

fukan

1573

Accepted

148K

0MS

C++

1189B

2013-08-08 22:51:40


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值