10311 - Goldbach and Euler

Problem L

Goldbach and Euler

Input: standard input

Output: standard output

Time Limit: 40 seconds

Memory Limit: 40 MB

 

“That every number which is resolvable into two prime numbers can be resolved into as many prime numbers as you like, can be illustrated and confirmed by an observation which you have formerly communicated to me, namely that every even number is a sum of two primes, and since (n-2) is also a sum of two prime numbers,n must be a sum of three, and also four prime numbers, and so on. If, however,n is an odd number, then it is certainly a sum of three prime numbers, since(n-1) is a sum of two prime numbers, and can therefore be resolved into as many prime numbers as you like. However, that every number is a sum of two primes, I consider a theorem which is quite true, although I cannot demonstrate it.”

 

-- Euler to Goldbach, 1742

The above conjecture about all numbers being the sum of two primes (where 1 counts as a prime) is not always true, but it is more true for even numbers. Your task is to test the conjecture for specified integers, considering that prime numbers are the numbers which are positive and divisible by exactly two positive integers. Your program must be very efficient.

Input

The input file contains 100000 lines of input. Each line contains a single integern (0<n<=100000000). Input is terminated by end of file.

 

Output

For each line of input produce one line of output. This line should be of one of the following types:


n is not the sum of two primes!n is the sum of p1 and p2.
 
For the second case, always make sure that (p2-p1) is positive and minimized.

 

Sample Input

11

12

 

Sample Output

11 is not the sum of two primes!12 is the sum of 5 and 7.
 
 
 
这道题坑爹的两个素数不能相同,害我wa了好久。。
 
#include<cstdio>
#include<iostream>
#include<cmath>

using namespace std;

int isprime(int a)
{
        if(a==1)
        return 0;
        for(int i=2;i<=sqrt(a);i++)
        if(a%i==0) return 0;
        return 1;
}
int main(void)
{
   int case1,n,left,right,flag;
   flag = 0;
   while(scanf("%d",&case1)!=EOF){
      n = case1;
      if(case1==1){
         printf("%d is not the sum of two primes!\n",n);
         goto end;}

      if(case1%2==0){

         flag =0;
         for ( int i = case1 / 2; i >= 2; --i )
            if ( isprime ( i ) && isprime ( case1 - i ) && i != ( case1 - i ) ) {
                    left = i, right =case1 - i, flag = 1;
                    break;
                }
         if(flag==1)
              printf("%d is the sum of %d and %d.\n",n,left,right);
         else{
              printf("%d is not the sum of two primes!\n",n);}
              goto end;
              }              

      case1 = case1 - 2;//奇数
      if(isprime(case1)==1)
         printf("%d is the sum of 2 and %d.\n",n,case1);
      else
         printf("%d is not the sum of two primes!\n",n);

end:
;
}
}




汉字字库存储芯片扩展实验 # 汉字字库存储芯片扩展实验 ## 实验目的 1. 了解汉字字库的存储原理和结构 2. 掌握存储芯片扩展技术 3. 学习如何通过硬件扩展实现大容量汉字字库存储 ## 实验原理 ### 汉字字库存储基础 - 汉字通常采用点阵方式存储(如16×16、24×24、32×32点阵) - 每个汉字需要占用32字节(16×16)到128字节(32×32)不等的存储空间 - 国标GB2312-80包含6763个汉字,需要较大存储容量 ### 存储芯片扩展方法 1. **位扩展**:增加数据总线宽度 2. **字扩展**:增加存储单元数量 3. **混合扩展**:同时进行位扩展和字扩展 ## 实验设备 - 单片机开发板(如STC89C52) - 存储芯片(如27C256、29C040等) - 逻辑门电路芯片(如74HC138、74HC373等) - 示波器、万用表等测试设备 - 连接线若干 ## 实验步骤 ### 1. 单芯片汉字存储实验 1. 连接27C256 EPROM芯片到单片机系统 2. 将16×16点阵汉字字库写入芯片 3. 编写程序读取并显示汉字 ### 2. 存储芯片字扩展实验 1. 使用地址译码器(如74HC138)扩展多片27C256 2. 将完整GB2312字库分布到各芯片中 3. 编写程序实现跨芯片汉字读取 ### 3. 存储芯片位扩展实验 1. 连接两片27C256实现16位数据总线扩展 2. 优化字库存储结构,提高读取速度 3. 测试并比较扩展前后的性能差异 ## 实验代码示例(单片机部分) ```c #include <reg52.h> #include <intrins.h> // 定义存储芯片控制引脚 sbit CE = P2^7; // 片选 sbit OE = P2^6; // 输出使能 sbit
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值