HDU 1016 DFS

Prime Ring Problem

Problem Description

 

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 


 

Input

 

n (0 < n < 20).
 


 

Output

 

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 


 

Sample Input

 

  
  
6 8
 


 

Sample Output

 

  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

素数环...1-n组成的环,每相邻两个数之和都是素数....

 

#include <iostream>
using namespace std;
/*
将从1到n这n个整数围成一个圆环,若其中任意2个相邻的数字相加,
结果均为素数,那么这个环就成为素数环。
*/
int n;
int start[20],result[20]={0,1};//start记录该数字是否用过,result判断是否素数
int prim[39]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0};
void dfs(int num,int count)//count计数
{
	if(count==n&&prim[result[n]+1])//最后一个与1的和为素数
	{
		printf("1");
		for(int i=2;i<=n;i++)
			printf(" %d",result[i]);
		printf("\n");
		return;
	}
	for(int k=2;k<=n;k++)
	{
		if(prim[num+k]&&start[k]==0)//num与其相邻的数相邻且
		{                        //这个相邻的数没有被用过
			result[count+1]=k;
			start[k]=1;
			dfs(k,count+1);
			start[k]=0;//查找后需将其初始化(多次查找)
		}
	}
}

int main()
{
	int Case=1;
	while(cin>>n)
	{
		memset(start,0,sizeof(start));
		printf("Case %d:\n",Case++);
		dfs(1,1);
		cout<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值