hdu 1806 Frequent values(RMQ)

Frequent values

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1443    Accepted Submission(s): 526


Problem Description
You are given a sequence of n integers a 1 , a 2 , ... , a n in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers a i , ... , a j . 

 

Input
The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a 1 , ... , a n(-100000 ≤ a i ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: a i ≤ a i+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the query. 

The last test case is followed by a line containing a single 0. 

 

Output
For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range. 
 

Sample Input
  
  
10 3 -1 -1 1 1 1 1 3 10 10 10 2 3 1 10 5 10 0
 

Sample Output
  
  
1 4 3
Hint
A naive algorithm may not run in time!
 


n个数 非降序给出 求任意区间内出现次数最多的数在这个区间出现的次数 

首先从数据最后开始初始化一个数连续出现的次数  然后 在一个区间内求值时分为两种情况 

一种是右端点到中间某个值 这是一段 可以求出坐标 然后相减得到长度 

一种是借助RMQ的想法求出区间的最大值 因为之前是从数据末尾开始初始化那个此数值的 所有从区间中段往左都是可以通过求最值得到答案的


#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 100010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int a[MAXN],b[MAXN],dp[MAXN][30];
int n;
void RMQ_init()
{
    for(int i=0;i<n;i++)
        dp[i][0]=b[i];
    for(int j=1;(1<<j)<=n;j++)
        for(int i=0;i+(1<<j)-1<n;i++)
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}

int RMQ(int l,int r)
{
    int k=0;
    while((1<<(k+1))<=r-l+1) k++;
    return max(dp[l][k],dp[r-(1<<k)+1][k]);
}

int bina(int s,int t)//找到区间中 值和右端点相同的位置
{
    int temp=a[t];
    while(s<t)
    {
        int mid=(s+t)/2;
        if(a[mid]>=temp) t=mid;
        else s=mid+1;
    }
    return t;
}

int main()
{
//    fread;
    while(scanf("%d",&n)&&n)
    {
        int q;
        scanf("%d",&q);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        int temp;
        for(int i=n-1;i>=0;i--)
        {
            if(i==n-1) temp=1;
            else
            {
                if(a[i]==a[i+1]) temp++;
                else temp=1;
            }
            b[i]=temp;
        }
        RMQ_init();
        while(q--)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            l--; r--;
            int temp=bina(l,r);
            int num=r-temp+1;
            r=temp-1;
            if(l>r) printf("%d\n",num);
            else printf("%d\n",max(num,RMQ(l,r)));
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值