poj 3666 Making the Grade (动态规划)

Making the Grade
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4647 Accepted: 2202

Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A B 1| + | A B 2| + ... + | AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

一个想法是:对于a[i],枚举任一高度作为最大高度,取前i-1个的合法最优解。

数据范围很大10^9,但n只有2000大小,可以离散化,用坐标代替高度。

a[i]存原始数组,b[j]存排序后递增的数组。

dp[i][j]=min(dp[i-1][0..j])+abs(a[i]-b[j]);  (把第i 个数高度改为b[j],此时的最小成本。)


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
#define ll __int64
#define mem(a,t) memset(a,t,sizeof(a))
#define N 2005
const int M=305;
const int inf=0x7fffffff;
int a[N],b[N];
int dp[N];
void solve(int n)
{
    int i,j,tmp;
    sort(b,b+n);
    for(i=0;i<n;i++)
    {
        dp[i]=abs(a[0]-b[i]);
    }
    for(i=1;i<n;i++)
    {
        tmp=dp[0];
        for(j=0;j<n;j++)
        {
            tmp=min(tmp,dp[j]);
            dp[j]=tmp+abs(a[i]-b[j]);
        }
    }
    int ans=inf;
    for(i=0;i<n;i++)
        ans=min(ans,dp[i]);
    printf("%d\n",ans);
}
int main()
{
    //freopen("in.txt","r",stdin);
    int i,n;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        b[i]=a[i];
    }
    solve(n);
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值