Flow Problem(HDU-3549)

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2

题意:给出一 n 个点 m 条边的有向图,求从 1 号点到 n 号点的最大流

思路:网络流最大流问题裸题,套 EK 算法模版即可,值得注意的地方是重边的处理

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 16007
#define INF 0x3f3f3f3f
#define N 101
#define LL long long
using namespace std;
struct EdmondsKarp{
    int n;
    int cap[N][N];
    int flow[N][N];

    void init(int n){
        this->n=n;
        memset(cap,0,sizeof(cap));
        memset(flow,0,sizeof(flow));
    }
    int maxFlow(int s,int t){
        int res=0;
        int dis[N];
        int p[N];

        queue<int> Q;
        while(true){
            memset(dis,0,sizeof(dis));
            dis[s]=INF;
            Q.push(s);

            while(!Q.empty()){
                int x=Q.front();
                Q.pop();
                for(int y=1;y<=n;y++){
                    if(!dis[y] && cap[x][y]>flow[x][y]){
                        p[y]=x;
                        Q.push(y);
                        dis[y]=min(dis[x],cap[x][y]-flow[x][y]);
                    }
                }
            }

            if(dis[t]==0)
                break;

            for(int x=t;x!=s;x=p[x]){
                flow[p[x]][x]+=dis[t];
                flow[x][p[x]]-=dis[t];
            }
            res+=dis[t];
        }
        return res;
    }

}EK;
int main(){
    int t;
    scanf("%d",&t);
    int Case=1;
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        EK.init(n);
        while(m--){
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            EK.cap[x][y]=+w;
        }
        printf("Case %d: %d\n",Case++,EK.maxFlow(1,n));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值