hdu 4709 - Herding【计算几何-三角形面积】

Herding
Time Limit:1000MS   Memory Limit:32768KB
Description:
Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.
 
Input:
The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case. 
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.
 
Output:
For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.
 
Sample Input:
1
4
-1.00   0.00
0.00   -3.00
2.00    0.00
2.00    2.00 
 
Sample Output:
2.00 


题意:
在一块草地上有编号为1 - N的树木,懒惰的John为了减少追赶牲畜的时间,John需要在这些树木中选择n颗树木,使其围成的农牧区面积尽可能小,并且农牧区面积可能为0


算法分析:
题目给出了n个点,求任意几个点能围成的最小图形的面积。因为多边形必然可继续切割成多个三角形,因此最小面积便是三角形。由于数据范围较小,可以直接枚举三角形的三点,来计算所有三角形中最小的面积。(注意共线情况不存在三角形)


代码实现:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <map>
#include <queue>
#include <vector>
#include <stack>
using namespace std;
const int Max = 100000;

struct Point
{
    double x, y;
    Point(double x = 0, double y = 0) : x(x), y(y){ }
};

typedef Point Vector;

Vector operator + (Vector A, Vector B)   {return Vector(A.x + B.x, A.y + B.y);}

Vector operator - (Vector A, Vector B)   {return Vector(A.x - B.x, A.y - B.y);}

Vector operator * (Vector A, double p)   {return Vector(A.x * p, A.y * p);}

Vector operator / (Vector A, double p)   {return Vector(A.x / p, A.y / p);}

double Cross(Vector A, Vector B)///叉积计算
{
    return A.x * B.y - A.y * B.x;
}

double Area2(Point A, Point B, Point C)///用叉积计算三角形面积
{
    return Cross(B - A, C - A) / 2.0;
}

int main()
{
    int t;
    double ans, tmp;
    Point po[105];
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
            scanf("%lf %lf",&po[i].x,&po[i].y);
        bool flag = false;
        tmp = 0.0;
        ans = 999999.0;
        for(int i = 0; i < n - 2; i++)///枚举所有点计算三角形面积
            for(int j = i + 1; j < n - 1; j++)
                for(int k = j + 1; k < n; k++)
                {
                    tmp = fabs(Area2(po[i],po[j],po[k]));
                    if(tmp < ans && tmp != 0.0)
                    {
                        ans = tmp;
                        flag = true;
                    }
                }
        if(flag)
            printf("%.2f\n",ans);
        else
            printf("Impossible\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值