poj 1458 Common Subsequence

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
 
LCS经典题目,重要的是推出递推公式,考虑到是否需要重新计算减少空间,直接贴代码
本题wa了两次,第一次是maxn开大了10010,导致超时,第二次开到110,太小,导致wa
ac之后用的是1010
 
/*
  time:11/24 2014
  poj:1458
  author:cj
  accept
*/


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;


const int maxn=1010;
char  x[maxn],y[maxn];
int dp[maxn][maxn];
int m,n;
int i,j;
int main(){
    while(scanf("%s",x+1)!=EOF){
        scanf("%s",y+1);
        memset(dp,0,sizeof(dp));
        m=strlen(x+1);
        n=strlen(y+1);


        //dp[0][0]=0;
        /*for(int i=0;i<m;i++){
            dp[i][0]=0;
        }*/
        /*for(int j=0;j<n;j++){
            //cout<<y[j]<<endl;
            printf("%c ",y[j]);
        }


        /*cout<<x[m]<<y[n]<<endl;
        if(x[0]==y[0]){
            dp[0][0]=1;
        }*/
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                if(x[i]==y[j]){
                    dp[i][j]=dp[i-1][j-1]+1;
                    //cout<<dp[i][j]<<endl;
                }
                else{
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }


            }
        }
        //cout<<x<<"***"<<y<<endl;*/
        //printf("%s m= %d\n",x,m);
        //printf("%s n= %d\n",y,n);
        cout<<dp[m][n]<<endl;


    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值