Pat(Advanced Level)Practice--1014(Waiting in Line)

Pat1014代码

题目描述:

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

额,好长的题目啊,真坑啊。。。注意题目的一句话 Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead,开始以为要在17:00之前完成服务,错了几次之后才知道必须在17:00之前开始服务,结束时间没有限制,如果顾客的开始时间为16:59,服务时间为534分钟,那不就太不科学了,那样还为他服务???
总之,本题没有什么算法技巧,运用STL会简化编程过程。。。
AC代码:
#include<cstdio>
#include<queue>
#define MAX 1001

using namespace std;

typedef struct customer
{
	int begin;
	int end;
	int trans;
}Customer;

Customer c[MAX];

int main(int argc,char *argv[])
{
	int n,m,k,q;
	int i,j;
	queue<int> windows[20];
	int now,shut_time;
	int count,to_finish;
	scanf("%d%d%d%d",&n,&m,&k,&q);
	for(i=1;i<=k;i++)
	{
		scanf("%d",&c[i].trans);
		c[i].begin=-1;
		c[i].end=-1;
	}
	now=0;
	shut_time=(17-8)*60;
	count=1;
	for(i=0;i<n&&count<=k;i++)//向N个窗口压入一个顾客,开始时间为零
	{                         //结束时间为交易时间
		windows[i].push(count);
		c[count].begin=0;
		c[count].end=c[count].trans;
		count++;
	}
	for(i=0;i<m-1&&count<=k;i++)//向N个窗口压入分别M-1个顾客,开始时间
		for(j=0;j<n&&count<=k;j++)//是上一个结束时间,结束时间是开始时间
		{                         //加上交易时间
			c[count].begin=c[windows[j].back()].end;
			c[count].end=c[count].begin+c[count].trans;
			windows[j].push(count);
			count++;
		}
	while(count<=k&&now<shut_time)//将第N*M+1以及之后
	{	                //顾客插入最先离开顾客的窗口
		to_finish=0;//其为即将完成交易的顾客的窗口编号
		for(i=1;i<n;i++)
		 if(c[windows[i].front()].end<c[windows[to_finish].front()].end)
			 to_finish=i;//找到最先完成的窗口号
		now=c[windows[to_finish].front()].end;
		windows[to_finish].pop();
		c[count].begin=c[windows[to_finish].back()].end;
		c[count].end=c[count].begin+c[count].trans;
		windows[to_finish].push(count);
		count++;
	}
	for(i=0;i<q;i++)
	{
		int query;
		scanf("%d",&query);
		if(c[query].end==-1||c[query].begin>=shut_time)//从某个顾客开始
			printf("Sorry\n");                     //还没服务就要关门了
		else
			printf("%.2d:%.2d\n",c[query].end/60+8,c[query].end%60);
	}

	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值