Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 13242 | Accepted: 5958 |
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Sample Input
4 8 2 1 2 4 1 3 2 1 4 7 2 1 1 2 3 5 3 1 2 3 4 4 4 2 3
Sample Output
10
Hint
Source
解题报告:题意抽象出来意思是给一个有向图,然后求所有点经过v点,再回到原点的所有最短路径中最长的一条。解题方法就是用两个dijkstra,分别求i到v的最短距离和v到i的最短距离,然后找出最大的即可。
/********************************/
/*Problem: POJ 3268 */
/*User: shinelin */
/*Memory: 4152K */
/*Time: 63MS */
/*Language: C++ */
/********************************/
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <cctype>
#include <cstring>
#include <string>
#include <list>
#include <map>
#include <queue>
#include <deque>
#include <stack>
#include <vector>
#include <set>
#include <algorithm>
#include <cmath>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MAXN 1005
int n, m, v;
int tab[MAXN][MAXN];
int Go[MAXN];
int Back[MAXN];
void dijkstra()
{
int s1[MAXN], s2[MAXN];
int Min1 = INF, Min2 = INF, u1, u2;
for(int i = 1; i <= n; i ++)
{
Go[i] = tab[i][v];
Back[i] = tab[v][i];
s1[i] = 0;
s2[i] = 0;
}
s1[v] = s2[v] = 1;
for(int i = 1; i <= n; i ++)
{
Min1 = Min2 = INF;
for(int j = 1; j <= n; j ++)
{
if(!s1[j] && Go[j] < Min1)
{
Min1 = Go[j];
u1 = j;
}
if(!s2[j] && Back[j] < Min2)
{
Min2 = Back[j];
u2 = j;
}
}
s1[u1] = 1;
s2[u2] = 1;
for(int j = 1; j <= n; j ++)
{
if(!s1[j] && tab[j][u1] != INF && tab[j][u1] + Go[u1] < Go[j])
{
Go[j] = Go[u1] + tab[j][u1];
}
if(!s2[j] && tab[u2][j] != INF && Back[u2] + tab[u2][j] < Back[j])
{
Back[j] = Back[u2] + tab[u2][j];
}
}
}
int Maxdist = 0;
for(int i = 1; i <= n; i ++)
{
if(Go[i] + Back[i] > Maxdist)
{
Maxdist = Go[i] + Back[i];
}
}
printf("%d\n", Maxdist);
}
int main()
{
int x, y, c;
scanf("%d%d%d", &n, &m, &v);
for(int i = 1; i <= n; i ++)
{
for(int j = i + 1; j <= n; j ++)
{
tab[i][j] = tab[j][i] = INF;
tab[i][i] = 0;
}
}
for(int i = 0; i < m; i ++)
{
scanf("%d%d%d", &x, &y, &c);
tab[x][y] = min(tab[x][y], c);
}
dijkstra();
return 0;
}