POJ 3268 Silver Cow Party(最短路dijkstra)

本文介绍了一道经典的最短路径问题——SilverCowParty。题目要求计算每头牛参加派对并返回农场所需的最长总时间。通过两次使用Dijkstra算法分别求得从各农场到派对地点及返回的最短路径,进而找到最大总时间。
摘要由CSDN通过智能技术生成

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13242 Accepted: 5958

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source


解题报告:题意抽象出来意思是给一个有向图,然后求所有点经过v点,再回到原点的所有最短路径中最长的一条。解题方法就是用两个dijkstra,分别求i到v的最短距离和v到i的最短距离,然后找出最大的即可。


/********************************/
/*Problem:      POJ 3268        */
/*User:         shinelin        */
/*Memory:       4152K           */
/*Time:         63MS            */
/*Language:     C++             */
/********************************/
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <cctype>
#include <cstring>
#include <string>
#include <list>
#include <map>
#include <queue>
#include <deque>
#include <stack>
#include <vector>
#include <set>
#include <algorithm>
#include <cmath>
using namespace std;

#define INF 0x7fffffff
#define LL long long
#define MAXN 1005

int n, m, v;
int tab[MAXN][MAXN];
int Go[MAXN];
int Back[MAXN];


void dijkstra()
{
    int s1[MAXN], s2[MAXN];
    int Min1 = INF, Min2 = INF, u1, u2;

    for(int i = 1; i <= n; i ++)
    {
        Go[i] = tab[i][v];
        Back[i] = tab[v][i];
        s1[i] = 0;
        s2[i] = 0;
    }

    s1[v] = s2[v] = 1;

    for(int i = 1; i <= n; i ++)
    {
        Min1 = Min2 = INF;

        for(int j = 1; j <= n; j ++)
        {
            if(!s1[j] && Go[j] < Min1)
            {
                Min1 = Go[j];
                u1 = j;
            }

            if(!s2[j] && Back[j] < Min2)
            {
                Min2 = Back[j];
                u2 = j;
            }
        }

        s1[u1] = 1;
        s2[u2] = 1;

        for(int j = 1; j <= n; j ++)
        {
            if(!s1[j] && tab[j][u1] != INF && tab[j][u1] + Go[u1] < Go[j])
            {
                Go[j] = Go[u1] + tab[j][u1];
            }

            if(!s2[j] && tab[u2][j] != INF && Back[u2] + tab[u2][j] < Back[j])
            {
                Back[j] = Back[u2] + tab[u2][j];
            }
        }
    }

    int Maxdist = 0;

    for(int i = 1; i <= n; i ++)
    {
        if(Go[i] + Back[i] > Maxdist)
        {
            Maxdist = Go[i] + Back[i];
        }
    }

    printf("%d\n", Maxdist);

}
int main()
{
    int x, y, c;
    scanf("%d%d%d", &n, &m, &v);

    for(int i = 1; i <= n; i ++)
    {
        for(int j = i + 1; j <= n; j ++)
        {
            tab[i][j] = tab[j][i] = INF;
            tab[i][i] = 0;
        }
    }

    for(int i = 0; i < m; i ++)
    {
        scanf("%d%d%d", &x, &y, &c);
        tab[x][y] = min(tab[x][y], c);
    }

    dijkstra();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值