HDU 1712 ACboy needs your help(分组背包)

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input

    
    
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output

    
    
3 4 6
 

解题报告:题目意思是给定acboy可以上的课程数以及acboy上课的总天数。之后给出矩阵a[i][j]表示,第i门课,acboy上j天就可以获得a[i][j]的收益。问最大可以获得多少收益。

这个明显就是a[i]中的a[i][j]最多只能选一个。所以应该把a[i]看成一个小组,对每个小组对象进行01背包,至于这个对象(小组)的内部需要找到一个最优的成员来代表这个小组。

所以就是在01背包的内层的加一层遍历一个小组中的所有成员,找到最合适的成员。

这个就是分组背包了。


#include <cstdio>
#include <cstring>
int a[105][105], dp[105], m, n, i, j, k;
int main() {
    while (~scanf("%d%d", &n, &m), m+n) {
        memset(dp, 0, sizeof(dp));
        for (i = 1; i <= n; i ++) {
            for (j = 1; j <= m; j ++) {
                scanf("%d", &a[i][j]);
            }
        }
        for (i = 1; i <= n; i ++) {           // 所有小组
            for (j = m;j >= 0; j --) {        // 小组01背包
                for (k = 1; k <= j; k ++) {   // 小组内部的成员
                    if(dp[j] < dp[j-k] + a[i][k]) {
                        dp[j] = dp[j-k] + a[i][k];
                    }
                }
            }
        }
        printf("%d\n", dp[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值