HDU 1098 Ignatius's puzzle

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5767    Accepted Submission(s): 3970


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43
此题应用费马小定理及中国剩余定理可以容易的得出如果存在a使得要求成立,则有:
a*k≡47(mod65)
所以得到此结论后便可遍历求出答案。
代码:
#include <iostream>
using namespace std;
#define N 65
int main()
{
    int n,s,i;
    while(cin>>n)
    {
        n=n%N;
        s=5*8*8+13*2*2;//中国剩余定理求出同余方程的解
        s=s%N;
       // cout<<s<<" "<<n<<endl;
        for(i=1;i<=N;i++)
        {
            if(i*n%65==s)
            {
                cout<<i<<endl;
                break;
            }
        }
        if(i>N)
            cout<<"no"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值