HDOJ 1098


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
  
  
11 100 9999
 
Sample Output
  
  
22 no 43
 
Author
eddy
 
分析如下:
 
只需验证x=1的时候成立即可,HDOJ上面的讨论区证明的很好,
对于为什么只验证x=1成立就能满足条件的证明如下:
 
因为   ( 5x^13+13x^5+kax )%65==0那么   5(x+1)^13+13(x+1)^5+ka(x+1)中间的二项式展开,其实都是65 的倍数,所以要想这个式子也成立, 那么它展开后必须满足(5+13+ka)%65==0,所以用x=1成立时,对任意的整数就都成立了。
 
对于给定范围的a只需要验证,是否存在一个a使得(18+k*a)%65==0。
a的范围从1到65,a=66时候开始出现循环。
 
代码如下:
 
#include <stdio.h>
int main()
{
	int k;
	int i;
	while(scanf("%d",&k)!=EOF)
	{
	
		for(i=1;i<=65;i++)
		{
		 
		
	
		  	if((18+k*i)%65==0) 
			{
				printf("%d\n",i);		
				break;
			}
		}
		if(i==66)printf("no\n");

	}	
	
	return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值