2010acm区域赛(哈尔滨)--Assignments(贪心水题)

Problem Description
In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what's more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers who work over the standard working hours, according to the company's rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum total of overtime pay.
 

Input
There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
 

Output
For each test case output the minimum Overtime wages by an integer in one line.
 

Sample Input
  
  
2 5 4 2 3 5
 

Sample Output
  
  
4
题目大意:一个工厂有N个员工,有A,B两种类型的任务,A需要xi的时间完成,B需要yi的时间完成,每个员工必须有两项任务分别为A和B,每个员工的工作时间为T,如果超过,老板要支付t-T的钱给员工,因为老板欲省钱,所以求最小的支付。本题明显是贪心的水题,直接把A由小到大排序,B由大到小排序,这样加起来的结果必定最小。下面为代码:
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1001;
int a[maxn];
int b[maxn];
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int m,n,i,j,sum,total;
    while(cin>>m>>n)
    {
        sum = 0,total = 0;
        for(i=0;i<m;i++)
            cin>>a[i];
        for(j=0;j<m;j++)
            cin>>b[j];
        sort(a,a+m);
        sort(b,b+m,cmp);
        for(i=0;i<m;i++)
        {
            sum = a[i] + b[i];
            //cout<<sum<<endl;
            if(sum>n)
            {
                total += sum - n;
            }
        }
        cout<<total<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值