hdu5361 In Touch 神奇的dij,神奇的写法

In Touch

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 784    Accepted Submission(s): 217


Problem Description
There are n soda living in a straight line. soda are numbered by  1,2,,n  from left to right. The distance between two adjacent soda is 1 meter. Every soda has a teleporter. The teleporter of  i -th soda can teleport to the soda whose distance between  i -th soda is no less than  li  and no larger than  ri . The cost to use  i -th soda's teleporter is  ci .

The  1 -st soda is their leader and he wants to know the minimum cost needed to reach  i -th soda  (1in)
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains an integer  n   (1n2×105) , the number of soda. 
The second line contains  n  integers  l1,l2,,ln . The third line contains  n  integers  r1,r2,,rn . The fourth line contains  n  integers  c1,c2,,cn (0lirin,1ci109)
 

Output
For each case, output  n  integers where  i -th integer denotes the minimum cost needed to reach  i -th soda. If  1 -st soda cannot reach  i -the soda, you should just output -1.
 

Sample Input
  
  
1 5 2 0 0 0 1 3 1 1 0 5 1 1 1 1 1
 

Sample Output
  
  
0 2 1 1 -1
Hint
If you need a larger stack size, please use #pragma comment(linker, "/STACK:102400000,102400000") and submit your solution using C++.
 

Source
 
dij算法求最短路的性质,与spfa不同已更新过的点的最短距离已经确定了。这道题用dij正合适,sq里是已更新过的点,se里是没更新过的点,为了使点不太多,每次更新se里的点时,把此点从se中删除,空间复杂度仅O(n).
#include<iostream>
#include<cstdio>
#include<set>
#define inf 1000000000000000
#define ll long long
using namespace std;
const int maxn=200005;
int n;
int l[maxn];
int r[maxn];
ll c[maxn];
ll dist[maxn];
set<int>se;
struct Node
{
    int id;
    ll w;
    Node(int a,ll b):id(a),w(b){}
    bool operator<(const Node& u)const
    {
        if(w+c[id]==u.w+c[u.id]) {
            return id<u.id;
        }
        return w+c[id]<u.w+c[u.id];
    }
};
set<Node>sq;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--) {
        se.clear();
        sq.clear();
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&l[i]);
        }
        for(int i=1;i<=n;i++) {
            scanf("%d",&r[i]);
        }
        for(int i=1;i<=n;i++) {
            scanf("%I64d",&c[i]);
        }
        for(int i=1;i<=n;i++)
            dist[i]=inf;
        dist[1]=0;
        sq.insert(Node(1,0));
        for(int i=2;i<=n;i++) {
            se.insert(i);
        }
        set<int>::iterator it;
        set<int>::iterator it2;
        while(!sq.empty()) {
            Node u=*sq.begin();
            sq.erase(sq.begin());
            it=se.lower_bound(u.id-r[u.id]);
            while(it!=se.end() && *it<=u.id-l[u.id]) {
                if(dist[*it]>u.w+c[u.id]) {
                    dist[*it]=u.w+c[u.id];
                    sq.insert(Node(*it,dist[*it]));
                    it2=it++;         //删除的巧妙写法
                    se.erase(it2);
                }
            }
            it=se.lower_bound(u.id+l[u.id]);
            while(it!=se.end() && *it<=u.id+r[u.id]) {
                if(dist[*it]>u.w+c[u.id]) {
                    dist[*it]=u.w+c[u.id];
                    sq.insert(Node(*it,dist[*it]));
                    it2=it++;
                    se.erase(it2);
                }
            }
        }
        printf("0");
        for(int i=2;i<=n;i++) {
            if(dist[i]==inf) {
                printf(" -1");
            }
            else {
                printf(" %I64d",dist[i]);
            }
        }
        puts("");
    }
    return 0;
}



评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值