B - I Hate It HDU 1754 (线段树+区间)


B - I Hate It
Time Limit:3000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 1754

Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。


Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。


Output
对于每一次询问操作,在一行里面输出最高成绩。


Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5



Sample Output

5
6
5

9

//线段树 的基础题,单点更新,区间的最大值

#include<bits/stdc++.h>
using namespace std;
const int maxn=200011;
const int inf=999999999;
#define lson (rt<<1),L,M
#define rson (rt<<1|1),M+1,R
#define M ((L+R)>>1)
#define For(i,n) for(int i=0;i<(n);i++)
template<class T>inline T read(T&x)
{
    char c;
    while((c=getchar())<=32);
    bool ok=false;
    if(c=='-')ok=true,c=getchar();
    for(x=0; c>32; c=getchar())
        x=x*10+c-'0';
    if(ok)x=-x;
    return x;
}
template<class T> inline void read_(T&x,T&y)
{
    read(x);
    read(y);
}
template<class T> inline void write(T x)
{
    if(x<0)putchar('-'),x=-x;
    if(x<10)putchar(x+'0');
    else write(x/10),putchar(x%10+'0');
}
template<class T>inline void writeln(T x)
{
    write(x);
    putchar('\n');
}
//-------IO template------

struct node
{
    int maxv;
    node(){maxv=0;}
}p[maxn<<2];

int n;
void build(int rt,int L,int R,int cnt)
{
    if(cnt>=n)return;
    if(L==R)
    {
        read(p[rt].maxv);
        return ;
    }
    build(lson,cnt+1);
    build(rson,cnt+1);
    p[rt].maxv=max(p[rt<<1].maxv,p[rt<<1|1].maxv);
}
void update(int rt,int L,int R,int i,int v)
{
    if(L==R)
    {
        p[rt].maxv=v;return ;
    }
    if(i<=M)
        update(lson,i,v);
    else
        update(rson,i,v);
    p[rt].maxv=max(p[rt<<1].maxv,p[rt<<1|1].maxv);
}

int query(int rt,int L,int R,int x,int y)
{
  //  printf("%d %d %d %d %d\n",rt,L,R,x,y);
    if(L==x&&y==R)
    {
        return p[rt].maxv;
    }
    if(y<=M)
        return query(lson,x,y);
    else if(x>M)
        return query(rson,x,y);
    else
        return max(query(lson,x,M),query(rson,M+1,y));
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int m,i,j,k,t;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,1,n,1);
        char op[2];
        //cout<<m<<endl;
        while(m--)
        {
            scanf("%s",op);
            int x,y;read_(x,y);
          //  printf("%s  %d %d\n",op,x,y);
            if(op[0]=='Q')
            {
                writeln(query(1,1,n,x,y));
            }
            else if(op[0]=='U')
            {
                update(1,1,n,x,y);
            }
        }
    }
    return 0;
}














  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值