uva11044 Searching for Nessy

Searching for Nessy
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA 11044
Appoint description:

Description
Download as PDF

The Loch Ness Monsteris a mysterious and unidentified animal said to inhabit Loch Ness,
a large deep freshwater loch near the city of Inverness in northern Scotland. Nessie is usually categorized as a type of lake monster.
http://en.wikipedia.org/wiki/Loch_Ness_Monster

In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBC team, using 600 separate sonar beams, found no trace of any ¨sea monster¨ (i.e., any large animal, known or unknown) in the loch. The BBC team concluded that Nessie does not exist. Now we want to repeat the experiment.

Given a grid of n rows and m columns representing the loch, 6 n, m 10000, find the minimum number s of sonar beams you must put in the square such that we can control every position in the grid, with the following conditions:

one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
the border cells do not need to be controlled, because Nessy cannot hide there (she is too big). 

For example,
这里写图片描述
这里写图片描述
where X represents a sonar, and the shaded cells are controlled by their sonar beams; the last figure gives us a solution.

Input

The first line of the input contains an integer, t, indicating the number of test cases. For each test case, there is a line with two numbers separated by blanks, 6 n, m 10000, that is, the size of the grid (n rows and m columns).

Output

For each test case, the output should consist of one line showing the minimum number of sonars that verifies the conditions above.

Sample Input

3
6 6
7 7
9 13

Sample Output

4
4
12

/*
Author:ZCC;
Solve:先去掉2个空格的,在去除3看看,能不能整除,不能的话
要加1
*/


using namespace std;
#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<string>
const int maxn=100005;
typedef long long LL;

const LL mod=1000000007;
LL dp[maxn];
int main(){
    #ifndef ONLINE_JUDGE
   // freopen("Text//in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int T;
    scanf("%d",&T);
    while(T--){
        int n,m;
        scanf("%d%d",&n,&m);
        n-=2;m-=2;
        int x=n/3,y=m/3;
        if(n%3!=0)x++;
        if(m%3!=0)y++;
        printf("%d\n",x*y);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值