Description
Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6 1 4 2 6 3 12 2 7
Sample Output
23
#include <cstring>
#include <stdio.h>#include <algorithm>
#include <iostream>
#include <cmath>
#include <map>
#include <queue>
using namespace std;
int N,M;
int w[4000];
int v[4000];
int dp[4000][400];
int main()
{
while(scanf("%d%d",&N,&M) != EOF)
{
memset(dp,0,sizeof(dp));
memset(w,0,sizeof(w));
memset(v,0,sizeof(v));
for(int i=1;i<=N;i++)
{
scanf("%d%d",&w[i],&v[i]);
}
for(int i=1;i<=N;i++)
{
for(int j=M;j>=0;j--)
{
if(j >= w[i])
dp[i][j] = max(dp[i-1][j],dp[i-1][j-w[i]] + v[i]);
}
}
for(int i=0;i<=N;i++)
{
for(int j=0;j<=M;j++)
{
cout << dp[i][j] << " " ;
}
}
printf("%d\n",dp[N][M]);
}
return 0;
}