poj 1001 解题报告

Exponentiation
Time Limit: 500MSMemory Limit: 10000K
Total Submissions: 115607Accepted: 28068

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
本题难点在于对数据的输出,考虑到数据存在首为0或末尾0等各种情况,首先将字符串倒序保存在整形数组里,
然后将用k储存该需要求幂数的值(去小数点),接着进行求小数对应的整数的幂;输出数据时,先要判断小数点位移数是否大于求得数组长度,如果大于,则表明该值只有小数部分,反之输出整数部分;再判断该小数点位移数与求得数的末尾0个数大小,如果小,则表明该结果只有整数部分,小数部分为0,反之输出小数部分;
 
//源代码如下:
#include <stdio.h>
#include <string.h>
int main()
{
  char s[6];
  int n;
  int a[130];
  int zan, next;
  int i, j, flag;
  int lena,k;
       while (scanf("%s%d",s,&n)!=EOF)
  {
  memset(a, 0, sizeof(a));
   lena = k = 0;
   for(i=5; i>=0; i--)
   {
    if(s[i]!='.')
    {
     a[lena++] = s[i]-'0';
    }
    else
    {
     flag = 5 - i;
    }
    }
 
   for (i=lena-1; i>=0; i--)
   {
    k = k*10+a[i];
   }
               //倒着进行求幂;
   for(i=0; i<n-1; i++)
   {
    for(j=0; j<lena; j++)
    {
     a[j] *= k;
    }
    zan = next = 0;
    for(j=0; j<lena; j++)
    {
     a[j] = a[j]+next;
    zan = a[j];
     next = a[j]/10;
     a[j] = zan;
    }
    while(next!=0)
    {
    a[lena++] = next;
     next /= 10;
    }
   }
                k = flag*n;//小数点位移数;
             //如果小数点位移数小于数组的长度,输出整数部分;
   for(i=lena-1; i>=k; i--)
   {
    printf("%d", a[i]);
  }
  
   //记录末尾为零的的个数;
   i = 0;
   while (a[i]==0)  i++;
  
   //末尾零的个数小于小数点位移数,输出小数点;
   if(k>i)
    printf(".");
             //输出小数点后面的数;
  for (j=k-1; j>=i; j--)
    printf("%d", a[j]);
   printf("\n");
  }
 
  return 0;
}
 
 
 
 
 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值