Ignatius's puzzle

                                                                                                            Ignatius puzzle

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output

The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

Sample Iutput

  
  
11 100 9999


Sample Output

  
  
22 no 43


释疑:根据第一个公式f(x)=5*x^13+13*x^5+k*a*x;及题目意思可知对于任何X满足,有归纳法可知只许证f(x+1)满足即可;证18+a*k;

满足即可,代码如下:

#include<stdio.h>
int main()
{
    int a,i,k;
    while(scanf("%d",&k)!=EOF)
    {
        for(a=1;a<=65;a++)
        {
            if((18+a*k)%65==0)
            {
                printf("%d\n",a);
                break;
            }
        }
        if(a>65)
            printf("no\n");
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值