POJ - 1426 Find The Multiple

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32497 Accepted: 13595 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:
        输入一个数n,求另一个数是n的倍数并且只包含0,1
题解:
        这题略坑。看到他给的数字长度是100位,我直接就用了字符串存,bfs搜索(当时内心默认的是输出最小的满足条件的值),然而超时。。。后来用这个程序打表发现数据正好在long long范围内,然后直接dfs。。不需要求出最小的值,只要满足条件,值多么离谱都能过,所以搜索可以写的非常暴力。

TLE代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<queue>
using namespace std;
int n,flag;
int check(string c)
{
    int mod=0,len=c.length();
    for(int i=0;i<len;i++)
    {
        mod=(mod*10+c[i]-48)%n;
    }
    if(mod==0)
    {
        cout<< c << endl;
        return 1;
    }
    return 0;
}
void bfs()
{
    queue<string> q;
    string s="";
    q.push(s);
    while(!q.empty())
    {
        string top=q.front(); q.pop();
        q.push(top+"1");
        if(check(top+"1"))
        {
            return;
        }
        if(top.compare("")==0)
            continue;
        q.push(top+"0");
        if(check(top+"0"))
        {
            return;
        }
    }
}
int main()
{
    while(scanf("%d",&n) && n)
    {
        flag=0;
        bfs();
    }
    return 0;
}

AC代码:
#include<stdio.h>
#include<string.h>
int n,flag;
void dfs(long long s,int step)
{
    if(flag || step==19)
        return;
    if(s%n==0)
    {
        flag=1;
        printf("%lld\n",s);
        return;
    }
    dfs(s*10,step+1);
    dfs(s*10+1,step+1);
}
int main()
{
    while(scanf("%d",&n) && n)
    {
        flag=0;
        dfs(1,0);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值