Proud MerchantsTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 6755 Accepted Submission(s): 2814
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
Sample Output
|
这一题关键在于按照(q-p)从小到大排序。保证有q金钱是取得较大的价值。之后就是0-1背包,注意一下限制条件就行了。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int dp[505][5005];
struct node
{
int p,q,v;
}obj[505];
bool cmp(node a,node b)
{
return a.q-a.p < b.q-b.p;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<n;i++)
scanf("%d%d%d",&obj[i].p,&obj[i].q,&obj[i].v);
sort(obj,obj+n,cmp);
memset(dp,0,sizeof dp);
for(int i=1;i<=n;i++)
{
for(int j=0;j<=m;j++)
{
if(j>=obj[i-1].q)
dp[i][j]=max(dp[i-1][j],dp[i-1][j-obj[i-1].p]+obj[i-1].v);
else
dp[i][j]=dp[i-1][j];
}
}
printf("%d\n",dp[n][m]);
}
return 0;
}