POJ 2482——Stars in Your Window(线段树+扫描线,二维区域最值转化为线段树-经典)最浪漫的题目

Stars in Your Window
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10044 Accepted: 2789

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

————————————————————————分割线——————————————————————


题目大意:

浪漫的情书。遇见这样的就嫁了吧

 

给你n颗星星的坐标,给你一个矩形区域,求在这个矩形区域内最大的星星亮度和


思路:

看了结题报告才会的自己完全没思路

看了n篇结题报告

下面搞    二维树状数组解法  和   扫面线+离散解法


//--------------------------------------------------------------------------------------------------------------------------//


要解决这个问题,首先要知道一个东西,就是给出一个一维的数列,怎么找出连续的,小于等于w个的数,它们的和最大。这个问题可以用线段树O(nlogn)地解决,在将一个数a放到x这个位置的同时,放一个相反数-a在x+w的位置,然后求出整个区间的最大和就是答案。注意,应该先插入-a,再插入a。




首先注意到最优解肯定是窗子的右上角(或其他角)在某个星星位置处(这里的在是模糊的在,略微比星星的位置大一点,能包含这个星星就行)。这样就将问题变成离散空间上的问题了。然后问题关键就是将二维问题变成一维问题,先只考虑x轴方向的一维,可以想到一个星星的起到的作用是一条长度为w的线段,然后答案就是找到被最多线段覆盖的某点,就是区间最值问题了。那么再考虑y轴这一维,这一维可以认为是线段的存活时间。那么将星星分成两条线段,一个代表出生,一个代表死亡,然后按照y坐标顺序插入星星(因为在每个y坐标出要么产生一个新的线段,要么减少一个线段,都会改变已有线段树的状态),线段树的作用就是维护一个区间最值。

我觉得类似的问题有林涛论文《线段树的应用》中的例题 “蛇”,也是有类似这种二维变一维,存活时间的思想。

// ------------------------                                                                             ——转载



对每个星星构建一个矩形,长度为w,宽度为h,下底边权值为c,上底边权值为-c

离散化横坐标,对高度h从小到大排序

维护最大前缀和

同一条线段前缀和相加,不同线段取最大

区间维护


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=22222;
using namespace std;
ll cnt[maxn<<2],sum[maxn<<2];
ll X[maxn<<1];
struct Seg
{
    ll l,r,h;
    int s;
    Seg(){};
    Seg(ll a,ll b,ll c,ll d):l(a),r(b),h(c),s(d){};
    bool operator<(const Seg&cmp)const{
        if(h==cmp.h) return s<cmp.s;
        return h<cmp.h;
    }
}ss[maxn];
void push_up(int rt)
{
    sum[rt]=max(sum[rt<<1],sum[rt<<1|1]);
}
void push_down(int rt)
{
    if(cnt[rt]) {
        sum[rt<<1]+=cnt[rt];
        sum[rt<<1|1]+=cnt[rt];
        cnt[rt<<1]+=cnt[rt];
        cnt[rt<<1|1]+=cnt[rt];
        cnt[rt]=0;
    }
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R) {
        cnt[rt]+=c;
        sum[rt]+=c;
        return ;
    }
    push_down(rt);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(m<R) update(L,R,c,rson);
    push_up(rt);
}
void solve(int m)
{
    memset(cnt,0,sizeof(cnt));
    memset(sum,0,sizeof(sum));
    sort(X,X+m),sort(ss,ss+m);
    int kx=unique(X,X+m)-X;
    ll ret=-1;
    for(int i=0;i<m;++i){
        int l=lower_bound(X,X+kx,ss[i].l)-X;
        int r=lower_bound(X,X+kx,ss[i].r)-X-1;
        if(l<=r)
            update(l,r,ss[i].s,0,m-1,1);
        ret=max(ret,sum[1]);
    }
    printf("%I64d\n",ret);
}
int main()
{
    int n,w,h;
    while(scanf("%d %d %d",&n,&w,&h)!=EOF){
        int m=0;
        ll x,y,c;
        while(n--){
            scanf("%lld %lld %lld",&x,&y,&c);
            X[m]=x;
            ss[m++]=Seg(x,x+w,y,c);
            X[m]=x+w;
            ss[m++]=Seg(x,x+w,y+h,-c);
        }
        solve(m);
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值