HDU 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28915    Accepted Submission(s): 12881


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
全排列需要根据实际情况稍作修改,本题的瓶颈是: 剪枝的时候条件不足,导致需要的空间变多,就会出现内存泄漏的状况。
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <algorithm>
#include <math.h>
using namespace std;

int is_prime(int m)
{
    for(int i=2;i*i<=m;i++)
    {
        if(m%i==0)
            return 0;
    }
    return 1;
}

void print_permution(int n,int *a,int cur)
{
    if(cur==n)
    {
        int ok=1;
              for(int i=0;i<n;i++)
        {
            if(i<n-1)
            {
                if(!is_prime(a[i]+a[i+1]))
                {
                    ok=0;
                    break;
                }

            }
            else
            {
                if(!is_prime(a[i]+a[0]))
                    ok=0;
            }
        }
        if(ok)
        {
            for(int i=0;i<n;i++)
            {
                if(i<n-1)
                printf("%d ",a[i]);
                else
                    printf("%d\n",a[i]);
            }
        }
    }
    else
    {
        for(int i=1;i<=n;i++)
        {
            int ok=1;
            for(int j=0;j<cur;j++)
               {
                    if(a[j]==i||a[0]!=1||is_prime(a[cur-1]+i)==0)
                    {
                         ok=0;
                         break;
                    }
               }
            if(ok)
            {
                a[cur]=i;
                print_permution(n,a,cur+1);
            }

        }
    }
}

int main(void)
{
    int n,j=1;
    while(scanf("%d",&n)!=EOF)
    {
        int a[50];
        a[0]=1;
        printf("Case %d:\n",j++);
        print_permution(n,a,0);
        printf("\n");

    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值