HDU 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11822 Accepted Submission(s): 7363


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.


Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)


Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output
45
59
6

13


一到很简单的深搜题,出错点在输入数据的时候,红色墙记为1,初始点也记为1,在进行到dfs函数里时,因为改点是记为已经走过的,肯定不能继续往下走了,把红墙记为1就好。

下一点和第一点是一样的错误,初始点是告诉你了,但是并不是说这一点已经遍历了。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int sum;
int n,m;
int vis[50][50];
char a[50][50];
void dfs(int x,int y)
{
  //  printf("%d %d\n",x,y);
 //   printf("fffffffffffffffffffffffd\n");
    if(x<1||x>m||y<1||y>n||vis[x][y]==1) return ;
    vis[x][y]=1;
    sum++;
    dfs(x+1,y);
    dfs(x-1,y);
    dfs(x,y+1);
    dfs(x,y-1);
}
int main(void)
{
   // freopen("B.txt","r",stdin);
    while(scanf("%d%d",&n,&m),(n||m))
    {
        sum=0;
        int x,y;
        for(int i=1;i<=m;i++)
        {
              getchar();
            for(int j=1;j<=n;j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='@')
                   {
                        x=i;
                        y=j;
                        vis[x][y]=0;
                   }
                else if(a[i][j]=='#')
                    vis[i][j]=1;
                else
                    vis[i][j]=0;
            }
        }
    /*    for(int i=1;i<=m;i++)
           {
            for(int j=1;j<=n;j++)
             printf("%c",a[i][j]);
              printf("\n");
           }
           for(int i=1;i<=m;i++)
           {
                for(int j=1;j<=n;j++)
              printf("%d",vis[i][j]);
              printf("\n");
           }
      */  dfs(x,y);
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值