HDU 1050 Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22480 Accepted Submission(s): 7587


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.




The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.




For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.


Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.


Output
The output should contain the minimum time in minutes to complete the moving, one per line.


Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


Sample Output
10
20

30


移动桌子,不能在走廊上移动相同区间的桌子,走廊的两边都有房间,奇数在上边,偶数在下边,将双边的区间问题变成单向的,若开始的位置是偶数,就减一,这就有两排区间变成了一排区间,结尾的位置亦然,变成单行区间后,在进行排序,最先开始的区间段在前边,若区间段开始的位置相同,再让区间段结束的位置靠前的在前。若区间段不重合就能同时进行,若重合,在下一个轮次再开始,用的大多数贪心都是用的算法模板。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct room
{
    int start;
    int end;
}room[300],r[300];

bool cmp(struct room a,struct room b)
{
    if(a.start!=b.start)
        return a.start<b.start;
    else
        return a.end<b.end;
}

int main(void)
{
   // freopen("D.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&room[i].start,&room[i].end);
            if(room[i].start>room[i].end)
            {
                int t;
                t=room[i].start;
                room[i].start=room[i].end;
                room[i].end=t;
            }
            if(room[i].start%2==0) room[i].start--;
            if(room[i].end%2) room[i].end++;
        }
        sort(room+1,room+n+1,cmp);
        r[1].start=room[1].start;
        r[1].end=room[1].end;
        int time=10;
        int k=1;
        for(int i=2;i<=n;i++)
        {
            int ok=0;
            for(int j=1;j<=k;j++)
               {
                    if(room[i].start>r[j].end)
                  {
                    r[j].end=room[i].end;
                    ok=1;
                        break;
                  }
               }
               if(ok==0)
               {
                   r[++k].start=room[i].start;
                   r[k].end=room[i].end;
                   time+=10;
               }
        }
        printf("%d\n",time);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值