hdu 2122 Ice_cream’s world III(最小生成树)

Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 


 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 


 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 


 

Sample Input
  
  
2 1 0 1 10 4 0
 


 

Sample Output
  
  
10 impossible

 

最小生成树

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAX=1005;
int father[MAX];
struct node
{
	int u;
	int v;
	int w;

	bool operator<(const node &t)const
	{
		return w<t.w;
	}
}e[MAX*10];
int Find(int x)
{
	if(x!=father[x])
	{
		father[x]=Find(father[x]);
	}
	return father[x];
}
void Union(int x,int y)
{
	x=Find(x);
	y=Find(y);
	if(x!=y)
	{
		father[x]=y;
	}
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
	
		int i;
		for(i=0;i<=n;i++)
		{
			father[i]=i;
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
		}
		sort(e,e+m);

		int sum=0;
		int ans=0;
		for(i=0;i<m;i++)
		{
			if(Find(e[i].u)!=Find(e[i].v))
			{
				ans++;
				Union(e[i].u,e[i].v);
				sum+=e[i].w;
			}
		}
		if(ans!=n-1)
		{
			printf("impossible\n");
		}
		else
		{
			printf("%d\n",sum);
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值