Hduoj1083 【匈牙利算法】【水题】

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3787    Accepted Submission(s): 1810


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
 

Source

#include<stdio.h>
#include<string.h>
#define Max  500
int a[Max], b[Max], map[Max][Max], mark[Max];//a代表左边数据, b代表右边数据,map表示连线,mark作为一个标记 
int p, n;//p 是左边数据的个数, n是右边数据的个数 
int path(int x)// 以x为出发点 求增广路径
{
	int  y;
	for(y = 1; y <= n; y++)//扫描右边的每个数据 
	{
		if(map[x][y] && !mark[y])//如果x和y有连线, 并且y点不在以x为出发点的增广路径上 
		{
			mark[y] = 1;//则 y点 可以 加入以x为出发点的增广路径上  若加入则递归时会起作用, 若不加人无影响 
			if( !b[y] || path(b[y]) )// 如果y点未覆盖,或者以y为起点有其它增广路径 ,则令y点和x匹配 
			{
				a[x] = y;
				b[y] = x;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int m, sum, i, j, k, num;
	scanf("%d", &m);
	while(m--)
	{
		memset(map, 0, sizeof(map));
		scanf("%d%d", &p, &n);
		for(i = 1; i <= p;  i++)//输入左边及右边的连线 
		{
			scanf("%d", &j);
			for(k = 1; k <= j; k++)
			{
				scanf("%d", &num);
				map[i][num] = 1;
			}
		}
		sum = 0;
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		for(i = 1; i <= p; i++)//以左边的点为起点,寻找最长增广路径 
		{
			memset(mark, 0, sizeof(mark));
			sum += path(i);
		}
		if(sum == p)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}

题意:给出两列数据,课程数以及学生数,学生可以选择已参观过的课程作为自己的课程,但是每门课程只能接受一个学生。求所能接受的最大学生数是否等于p。

思路:将其看作二分匹配,求出最大的匹配数,看其是否与p相等。

体会:匈牙利算法主要是在于一个寻找增广路径的递归算法,若能理解递归部分,基本上就能理解该算法了。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值