1041. Be Unique (20)

1041. Be Unique (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
输出只出现一次的最早出现的或None

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月06日 21:05答案正确201041C++ (g++ 4.7.2)26728datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确134011/11
1答案正确13081/1
2答案正确13082/2
3答案正确13082/2
4答案正确267282/2
5答案正确267242/2
#include <iostream>  
#define MAX 10000
#define L 100000
using namespace std;  
int main()
{ 
  int index;
  int N;
  int bet[L];
  int bets[MAX] = {0};
  bool Flag;
  cin >> N;
  for ( index = 0; index < N;index++)
  {
    cin >> bet[index];
    bets[bet[index]]++;
  }
  Flag = true;
  for (index = 0; index < N&&Flag; index++)
    if (bets[bet[index]] == 1)
      Flag = false;
  if (Flag)cout << "None" << endl;
  else cout << bet[index-1] << endl;
  system("pause");
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值