1069. The Black Hole of Numbers (20)

102 篇文章 0 订阅
29 篇文章 0 订阅

1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
输入一个数N;
  如果这个数是XXXX  X都一样那么输出XXXX - XXXX = 0000
  否则这个数的各个位数  组成的最大的  减去  组成的最小的 =结果  按形式输出,如果此时结果为6174或者XXXX结束;(此处至少进行一次,测试数据中有:如果输入的是6174也是要执行这样的一次的)
下面一个ac的,还有一个超时的

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月14日 11:33答案正确201069C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确11802/2
1答案正确130810/10
2答案正确11802/2
3答案正确13002/2
4答案正确11802/2
5答案正确13081/1
6答案正确11801/1

#include<iostream>
#include<string>
#include<iomanip>
#include<algorithm>
using namespace std; 
bool charcmp(const char&a, const char &b)
{
  return a > b;
}     
int main()
{
  char N[5];
  int most, less; 
  cin >> most;
  do
  { 
    sprintf(N, "%04d", most);
    sort(N,N+4,charcmp);
    sscanf(N, "%d", &most);
    reverse(N, N + 4);
    sscanf(N, "%d",&less);
    cout << setw(4) << setfill('0') << most << " - " << setw(4) << setfill('0') << less << " = ";
    most = most - less;
    cout << setw(4) << setfill('0') << most << endl;
  } while (0!=most&&most!=6174);
    system("pause");
  return 0;
}

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月14日 11:17部分正确141069C++ (g++ 4.7.2)1384datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确11802/2
1答案正确130810/10
2运行超时  0/2
3运行超时  0/2
4运行超时  0/2
5答案正确13841/1
6答案正确11801/1

#include<iostream>
#include<string>
#include<algorithm>
using namespace std; 
bool charcmp(const char&a, const char &b)
{
  return a > b;
}
bool ThesameOrcontinnue(char*N)
{ 
  if (N[0] == N[1] && N[0] == N[2] && N[0] == N[3] )
  {
    cout << N << " - " << N << " = 0000" << endl;
    return false;
  } 
  else 
  {
    sort(N, N + 4, charcmp); 
    cout << N<<" - ";
    int c = 0,index=4;
    string tempN;
    tempN = N;
    while (index--)
    {
      cout << tempN[index];
      c = tempN[index]-tempN[3-index] - c;
      if (c >= 0)
      {  
        N[index] = c  + '0';
          c = 0;
        }
      else
      {
        N[index] = c + 10 + '0';
        c = 1; 
      }
    }
    cout << " = " << N << endl;
  } 
  if (N[0] == '6'&& N[1] == '1' && N[2] == '7' && '4' == N[3])
    return false;
  return true;
}
int main()
{
  char N[5];
  bool Flag=true;
  cin >> N;
  while (Flag)
  {
    Flag = ThesameOrcontinnue(N);  
  }
    system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值