HDU 1011 Starship Troopers(树形dp+背包)

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13109    Accepted Submission(s): 3562


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7
 

Author
XU, Chuan
 

Source

/*

题意:起点1,然后n个点,m个人,每一个节点有 cost 和va,一个人最多消灭20个cost
     但是不能走一个节点两遍,消灭一个节点的全部cost后得到这个节点的va,
     而且消灭他的人不能再用了,求这m个人最多可以得到多少 va

思路: 树形dp+背包,背包部分在代码写出


*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

using namespace std;

#define INF 0x3f3f3f3f
#define N 155

vector<int>g[N];

int dp[N][N];
int cost[N],va[N];
int n,m;
int vis[N];

void dfs(int u)
{
    int i,j;
    int lim=(cost[u]+19)/20;
    for(i=lim;i<=m;i++)
	   dp[u][i]=va[u];

	vis[u]=1;
	for(i=0;i<g[u].size();i++)
	{
	     int to=g[u][i];
	     if(vis[to]) continue;
	     dfs(to);
	     for(int v=m;v>=lim;v--)     //假设这个点的人数最大为m,
	                                 // 那么依次求人数在m~lim时的最大情况(背包)
			for(int co=1;v-co>=lim;co++)   //枚举分几个人给to节点
			  dp[u][v]=max(dp[u][v],dp[u][v-co]+dp[to][co]);
	}
}

int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m))
	{
		if(n==-1&&m==-1) break;
		for(i=1;i<=n;i++)
			scanf("%d%d",&cost[i],&va[i]);
		for(i=0;i<=n;i++)
			g[i].clear();

		int u,v;
		for(i=1;i<n;i++)
		{
			 scanf("%d%d",&u,&v);
		     g[u].push_back(v);
		     g[v].push_back(u);
		}
		if(m==0)     //这个地方很重要,对于起点没有cost的情况,没有这个会挂
		{
			printf("0\n");
			continue;
		}
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        dfs(1);
	   printf("%d\n",dp[1][m]);
	}
   return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值