【匈牙利算法二分图匹配】 C - Courses HDU - 1083

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10555    Accepted Submission(s): 4983


 

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 

 

Sample Input

 

2

3 3

3 1 2 3

2 1 2

1 1

3 3

2 1 3

2 1 3

1 1

 

 

Sample Output

 

YES

NO

 

 

Source

Southeastern Europe 2000

 

/// 邻接矩阵 O(n^3) 邻接表 O(nE)

#include <bits/stdc++.h>
using namespace std;

const int mp = 105, mn = 305;

int p, n;
bool s[mp][mn];
bool use[mn];
int xue[mn];

bool dfs(int x)
{
	for (int i = 1; i <= n; i++) /// 遍历每个学生
	{
		if (s[x][i] && !use[i]) // 未访问
		{
			use[i] = 1; // 标记
			if (!xue[i] || dfs(xue[i])) /// i的对应可被修改
			{
                xue[i] = x; // i 对应为 x
                return 1; /// 可匹配
			}
		}
	}
	return 0; /// 找不到匹配
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d %d", &p, &n);
		memset(s, 0, sizeof s);
		for (int i = 1; i <= p; i++)
		{
			int t;
			scanf("%d", &t);
			while (t--)
			{
				int a;
				scanf("%d", &a);
				s[i][a] = 1;  // 连通
			}
		}

		bool flag = 1;
		memset(xue, 0, sizeof xue);
		for (int i = 1; i <= p; i++)
		{
			memset(use, 0, sizeof use);  // 每次更新为未使用
			if (!dfs(i))  /// i 找不到区配
			{
				flag = 0;
				break;
			}
		}
		if (!flag)
			printf("NO\n");
		else
			printf("YES\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值