【manacher】S - Best Reward HDU - 3613

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4141    Accepted Submission(s): 1686


 

Problem Description

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.

 

 

 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000.

 

 

 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

 

 

Sample Input

 

2

1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

aba

1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

acacac

 

 

Sample Output

 

1

6

 

 

Source

2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU

 

切割字符串成两部分,每部分如为回文则有一定价值
问不同切割位置最大的总价值

#include <bits/stdc++.h>
using namespace std;

const int mn = 500010;

char ch[mn];
int val[30], VAL[mn];

char temp[2 * mn];
int tp[2 * mn];
void manacher(char ch[])
{
	int len = strlen(ch);

	temp[0] = '@';
	for (int i = 1; i <= 2 * len; i += 2)
	{
		temp[i] = '#';
		temp[i + 1] = ch[i / 2];
	}
	temp[2 * len + 1] = '#';
	temp[2 * len + 2] = '$';
	temp[2 * len + 3] = '\0';
	int tlen = 2 * len + 1;

	int mx = 0, id = 0;
	for (int i = 1; i <= tlen; i++)
	{
		if (mx >= i)
			tp[i] = min(tp[2 * id - i], mx - i + 1);
		else
			tp[i] = 1;

		while (temp[i - tp[i]] == temp[i + tp[i]])
			tp[i]++;

		if (mx < i + tp[i] - 1)
		{
			mx = i + tp[i] - 1;
			id = i;
		}
	}
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("C:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE

	int T;
	scanf("%d", &T);
	while (T--)
	{
		for (int i = 0; i < 26; i++)
		{
			int t;
			scanf("%d", &t);
			val[i] = t;
		}
		scanf("%s", ch);
		int len = strlen(ch);

		VAL[0] = val[ch[0]- 'a'];
		for (int i = 1; i < len; i++)
			VAL[i] = VAL[i - 1] + val[ch[i] - 'a'];

		manacher(ch);

		int ans = -0x3f3f3f3f;
		int tlen = 2 * len + 1;
		for (int i = 3; i < tlen; i++)
		{	/// 枚举切割点
			if (temp[i] == '#')
			{
				int l = 0, r = 0;
				if (tp[(i + 1) / 2] == (i + 1) / 2) // 左侧回文
					l = VAL[i / 2 - 1];
				if (tp[(i + tlen) / 2] == (tlen - i) / 2 + 1) // 右侧回文
					r = VAL[len - 1] - VAL[i / 2 - 1];
				ans = max(ans, l + r);
			}
		}
		printf("%d\n", ans);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值