Square(DFS)

11 篇文章 0 订阅
6 篇文章 0 订阅

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square? 
 

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000. 
 

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no". 
 

Sample Input

    
    
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output

    
    
yes no yes
 

解题思路:

题目大意就是给你一堆木棒,全部用上后,看能否拼成一个正方形。由于木棒已经给出,所以可以计算出该正方形的边长。用DFS枚举出所有可能的情况,并且需要剪枝,否则超时。正方形四条边,一条一条检索,第一条边用DFS搜索,如果能构成边就进行下一条边的DFS搜索,依次类推,如果该边无法构成,就回溯到前一个访问点,并把刚才访问的点重新赋为未访问过,因为下一条边可能还需要用上。如果始终未构成边就回溯到上一条边,重新进行检索。如果一直回溯到第一条边说明给的木棒无法构成正方形。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100;
int n, m, len[maxn], sum;
bool visited[maxn], flag;
void Dfs(int now, int length, int pos)   // now 是当前第几条边,length是当前构成边的长度,pos是标记点
{
    if(now == 5)    // 如果已经到了第五条,说明前四条都已经找到。当然其实如果我们找到了第三条,第四条一定能找到,读者可自行优化。
    {
        flag = true;
        return;
    }
    if(length == sum / 4)  // 木棒构成了一条边就检索下一条
    {
        Dfs(now + 1, 0, 0);
        if(flag)   // 能组成正方形就立即返回
            return;
    }
    for(int i = pos; i < m; i++)
    {
        if(length + len[i] > sum)  // 如果已经超出边长长度就不需要继续检索了
            return;
        if(!visited[i] && length + len[i] <= sum / 4)
        {
            visited[i] = 1;  
            Dfs(now, length + len[i], i + 1);
            if(flag)                               // 能组成正方形就立即返回
                return;
            visited[i] = 0;   // 回溯的时候记得清零
        }
    }
}
int main()
{

    scanf("%d", &n);
    while(n--)
    {
        sum = 0;
        scanf("%d", &m);
        for(int i = 0; i < m; i++)
        {
            scanf("%d", &len[i]);
            sum += len[i];
        }
        sort(len, len + m);
        if((sum % 4 != 0) || (len[m - 1] > sum / 4))  // 不能被4整除或者有木棒超出边的长度一定不能构成,直接输出
            printf("no\n");
        else
        {
            memset(visited, 0, sizeof(visited));
            flag = false;
            Dfs(1, 0, 0);
            if(flag)
                printf("yes\n");
            else
                printf("no\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值