Prime Ring Problem(DFS)

11 篇文章 0 订阅
6 篇文章 0 订阅

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

    
    
6 8
 

Sample Output

    
    
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

解题思路:

用DFS检索所用的情况,如果满足条件输出即可,因为数不超过20,所以可以枚举出所有40以内的素数。一开始脑子抽筋,只枚举了20以内的素数,WA了一发,没有考虑到虽然数字不超过20,但两个数相加是不超过40,所以得枚举40以内的素数。。。。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 25;
int n, num[maxn] = {0,1},prime[11] = {3,5,7,11,13,17,19,23,29,31,37};
bool visited[maxn];
bool isPrime(int a)
{
    for(int i = 0; i < 11; i++)
    {
        if(a == prime[i])
            return true;
    }
    return false;
}
void Dfs(int x)
{
    if(x == n && isPrime(num[x] + 1))  // 最后一个数要判断和1相加是否为素数,这样就构成了环
    {
        for(int i = 1; i <= n; i++)
        {
            if(i == n)
                printf("%d\n",num[i]);
            else
                printf("%d ",num[i]);
        }
        return;
    }
    for(int i = 2; i <= n; i++)
    {
        if(!visited[i] && isPrime(num[x] + i))
        {
            visited[i] = 1;
            num[x + 1] = i;
            Dfs(x + 1);
            visited[i] = 0;
        }
    }
    return;
}
int main()
{
    int count = 0;
    while(scanf("%d", &n) != EOF)
    {
        memset(visited, 0, sizeof(visited));
        printf("Case %d:\n",++count);
        Dfs(1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值