ZOJ - 4125:Sekiro

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying  amount of money, the amount of money will be reduced to , where  indicates the smallest integer that .

As a noobie of the game, BaoBao has died  times in the game continuously. Given that BaoBao carried  amount of money before his first death, and that BaoBao didn't collect or spend any money during these  deaths, what's the amount of money left after his  deaths?

Input

There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers  and  (, ), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output

For each test case output one line containing one integer, indicating the amount of money left after  deaths.

Sample Input

4
10 1
7 1
10 2
7 2

Sample Output

5
4
3
2

Hint

For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
long long n,k,chushu;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>k;
        chushu = (long long)pow(2,k);
        if(n%chushu == 0)
            cout<<n/chushu<<endl;
        else
            cout<<n/chushu+1<<endl;;

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

朱事顺利、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值