POJ 2376 Cleaning Shifts

题目
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
Line 1: Two space-separated integers: N and T
Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2

题意:判断能否从头到尾都有牛在工作,如果能,最少要有几头牛

#include <stdio.h>
#include <algorithm>
using namespace std;
int n,t;
struct node  //结构体保存开始时间和结束时间
{
	int s,e;
};
node arr[1000010];
bool cmp(node a,node b)
{
	if(a.s!=b.s) return a.s<b.s;  //按开始时间从小到大排序
	else return a.e<b.e;  //如果开始时间相同就按结束时间排序
}
int main()
{
	scanf("%d%d",&n,&t);
	for(int i=0;i<n;i++)
	    scanf("%d%d",&arr[i].s,&arr[i].e);
	sort(arr,arr+n,cmp);
	if(arr[0].s!=1)  //最小的开始时间不等于1说明牛的工作时间不能覆盖整个时间段
	{
		printf("-1\n");
		return 0;
	}
	int start=1,end=-1,c=1;
	for(int i=0;i<n;i++)
	{
		if(arr[i].s<=start)  //除start==1时,start实质上是上一头牛工作结束时间+1,所以这条语句实质上是判断两头牛的工作时间是否可以衔接上(实际上下面的else if(arr[i].s<=end+1)  中已经判断过)
		{
			if(arr[i].e>end)  //当前牛的工作结束时间大于已存在结束时间时才更新结束时间,防止同一时段有多头牛工作,最大限度利用每头牛的工作时间
			    end=arr[i].e;
			if(end>=t)  //当前结束时间大于规定结束时间时说明已覆盖全部工作时区,结束程序
			{
				printf("%d\n",c);
				return 0;
			}
		}
		else if(arr[i].s<=end+1)  //arr[i].s<=end+1保证两头牛的工作时间可以衔接上
		{
			start=end+1; 
			c++;
			i--;  //执行这条语句后才能依据这头牛的工作结束时间更新整个区间结束时间,否则会未判断这一头牛的结束时间就直接跳到下一头牛,无法更新结束时间
		}  //这个else if 其实在为上面的if做前提工作
		else 
		{
			printf("-1\n");
		    return 0;
		}
	}
	if(end>=t)
	{
		printf("%d\n",c);
		return 0;
	}
	printf("-1\n");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值