HDUoj 1078 - FatMouse and Cheese ( dp+dfs

Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

ut
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

Hint

题意

从一个正方形的0,0点开始走,只能横着走,竖着走,最多走k步,下一个点的数一定要比当前这个点的值大,每走一步,就加上下一个点的数据,问数据最大能有多少。

题解:

dp+ dfs
1、只能从0,0开始走,所以已经减少了很多复杂了,不要傻乎乎的全部循环。

2、注意dfs时候的边界判断。

3、更新值时不要忘记加上当前自己的值。

状态转移方程

dp[][] = max(所有可以从当前点走到的点的dfs的结果集)

AC代码

#include <bits/stdc++.h>
using namespace std;

const int N = 110;
int dp[N][N], maps[N][N];
int dx[] = {1, 0, -1, 0};
int dy[] = {0, 1, 0, -1};
int n, k;
bool check(int x,int y)
{
    return x>=0&&y>=0&&x<n&&y<n;
}
int dfs(int x,int y)
{
    int maxx = 0, xx, yy, ans;
    if(!dp[x][y]) {
        for(int i = 1;i <= k; i++) {
            for(int j = 0; j < 4; j++) {
                xx = x + dx[j]*i;
                yy = y + dy[j]*i;
                if(check(xx,yy) && maps[xx][yy]>maps[x][y]) {
                    ans = dfs(xx,yy);
                    if(ans > maxx) maxx = ans;
                }
            }
        }
        dp[x][y] = maxx + maps[x][y];
    }
    return dp[x][y];
}
int main()
{
    while(~scanf("%d%d",&n,&k),n+k+2) {
        memset(dp,0,sizeof(dp));
        for(int i = 0;i < n; i++) {
            for(int j = 0;j < n; j++) {
                scanf("%d",&maps[i][j]);
            }
        }
        printf("%d\n",dfs(0,0));
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值