POJ 2299 Ultra-QuickSort (BIT / 归并排序

Ultra-QuickSort

题目描述

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

输入

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

输出

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

样例

Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0

题意

裸的求归并排序的题目 忘记会爆int了 wa了两发 sad

AC代码

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))

const LL MAXN = 1e6+10;
LL c[MAXN], a[MAXN];
LL n;
struct node {
    LL v, pos;
    bool operator < (const node &r) const {
        return v < r.v;
    }
}p[MAXN];

LL lowbit(LL x) {
    return x&(-x);
}
LL query(LL x) {
    LL res = 0;
    while(x) {
        res += c[x];
        x -= lowbit(x);
    }
    return res;
}
LL add(LL x,LL d) {
    while(x <= n) {
        c[x] += d;
        x += lowbit(x);
    }
}

int main() {
    ios::sync_with_stdio(false);
    while(cin >> n,n) {
        CLR(a,0); CLR(c,0);
        LL ans = 0;
        for(LL i = 1; i <= n; i++) {
            cin >> p[i].v;
            p[i].pos = i;
        }
        sort(p+1,p+1+n);
        LL k = 0;
        p[0].v = -1;
        for(LL i = 1; i <= n; i++) {
            if(p[i].v != p[i-1].v) k++;
            a[p[i].pos] = k;
        }
        for(LL i = 1; i <= n; i++) {
            add(a[i],1);
           // cout << query(a[i]) <<endl;
            ans += i-query(a[i]);
        }
        cout << ans << endl;
    }

    return 0;
}
/*
5
5 4 3 2 1
*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值