文章标题

Time Limit: 0.1 seconds (C/C++)
Memory Limit: 256 megabytes
You are given two natural numbers A and B. Determine the natural number N such that the least
common multiple of the numbers A + N and B + N is minimal.
Input
The only line of the input contains two natural numbers: A and B. None of them is exceeding 109
.
Output
Output the natural number N such that LCM(A + N, B + N) is minimal. If there are several values
of N which yield the minimum, output the smallest one.
acm
Sample input Sample output
4 10
2

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<set>
#include<algorithm>
#include<iostream>
#include<string>
#include<climits>
#include<map>

using namespace std;
typedef long long ll;
const ll inf = LLONG_MAX;
set<ll> s;
set<ll>::iterator p;

ll gcd(ll a,ll b){
    if(b == 0)
        return a;
    else
        return gcd(b,a%b);
}

ll lcm(ll a,ll b){
   return a/gcd(a,b)*b;
}

void factor(ll n){//求因子
    s.insert(1);
    s.insert(n);
    ll temp,now;
    temp = (ll)((double)sqrt((double)n)+1);
    now = n;
    for(ll i = 2;i <= temp;i++)
        if(now%i == 0){
            s.insert(i);
            s.insert(now/i);
        }
    if(now != 1)
        s.insert(now);
}

int main(){
    ll a,b;
    while(cin>>a>>b){
        if(a == b)
          cout << 1 << endl;
        else {
            ll res = inf;
            s.clear();
            ll number = abs(a - b);
            factor(number);
            ll ans = inf;
            for(p=s.begin();p!=s.end();p++){
                ll n = (*p) - a% (*p);
                if(lcm(a+n,b+n) < res){
                    res = lcm(a+n,b+n);
                    ans = n;
                }else if(lcm(a+n,b+n) == res){
                    ans = min(ans,n);
                }
            }
            cout << ans << endl;
         }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值