HDU

Problem C

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 29   Accepted Submission(s) : 12
Problem Description
A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?
 

Input
Each line of input contains three positive floating point numbers giving the values of x, y, and c.
 

Output
For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.
 

Sample Input
 
  
30 40 10 12.619429 8.163332 3 10 10 3 10 10 1
 

Sample Output
 
  
26.033 7.000 8.000 9.798
 

其实这是一道几何题来着(要用到二分):
ac代码:
#include<iostream>  
#include<cstdio>
#include<cmath>  //sqrt什么的要用
#define min(a,b) a <= b ? a : b;
using namespace std;
double x, y, c;
double get1(double w)
{
    return 1 - c / sqrt(x * x - w * w) - c / sqrt(y * y - w * w);//无奈高数学得
   //不怎么样,所有这里推了半天,其实利用相似三角形马上可以求解;
}
int main()
{
    while(~scanf("%lf%lf%lf",&x,&y,&c))
    {
        double l = 0, mid, r = min(x,y);
        while(r - l > 1e-8)
        {
            mid = (l + r) / 2;
            if(get1(mid) > 0)
                l = mid;
            else
                r = mid;
        }
        printf("%.3f\n",mid);  //小心,别用%.3lf,就是过不了!!!
    }
    return 0;
}


若能留下您宝贵的建议,
万分感谢~~~ 吐舌头

转载于:https://www.cnblogs.com/zhanpang/p/5682918.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值